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This user manual is intended for customers who have purchased GYPRO® or AXO® Evaluation Board and who would like to
implement it using Arduino platform. The following paragraphs explain how to set-up the full evaluation kit and how to
configure Arduino Leonardo or Yun Rev.2 board.

Required:
- GYPRO® or AXO® EVB
- Header Connectors (x5)

- Arduino Leonardo board or Arduino Yun Rev. 2 Board (not included).

- Micro-B USB Cable (not included).
- Computer running Window 7 or later version with USB port.

Note: If you intend to perform tests over temperature, make sure that your USB Cable can withstand the operating temperature

range specified by Tronics

1. System Requirements

Tronics Evaluation Tool software is compatible with OS Windows 7 or later versions. The program automatically adapts to the
operating system on which it runs, eliminating the need for manual settings.

Recommended system configuration:
* Processor 1.6 GHz or faster
* 8 GBRAM

* 1280*960 pixels minimal screen resolution

* USB Port

* Operating Systems: Windows 11, Windows 10, Windows 7
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2. Setting Up
2.1. Installing Arduino IDE

5. The installation of Arduino IDE includes “Atmel USB

1. |Install open-source Arduino software (IDE) Driver Package” installation. You don’t need to install
1.X.X.windows.exe (please authorize the driver this package if you don’t use other boards than the
installation process). Arduino Leonardo or Arduino Yun in the future.

NOTE: link to the software version is available on our

Website. # Atmel USE Driver Package Setup — X

Atmel USB Driver Package
Ie - X
Chedk ﬂ?e mmpon_ems you_want to install and uncheck the components
you don't want to install. Clidk Next to continue. MOd ”cy SetU p

Select components to install: Install Arduino software
Install USB driver
Create Start Menu shortcut
Create Desktop shortcut
Assodiate .ino files

Repair Uninstall Close
Space required: 392, 7MB
Cancel | Nulsoft Install System v2.45 <Back Next > 6. Once the status “Completed” is displayed, Arduino
IDE is installed and is ready to be used. You can close
. the Installer.

2. Select all the components and then click on “Next”
button.

@ Arduine Setup: Completed —

3. Choose the installation directory (we suggest to keep feve) Complet=d

the default one) then click on the “Install” button.

Show details |

@ Arduino Setup: Installation Felder — *

Setup will install Arduine in the following folder. To install in a different
2.2 folder, dick Browse and select another folder. Click Install to start the
installation.

"Desﬁnanon Folder

C:\Program Files (x86)\Arduino Browse... |

Cancel | Mullsaft Install System < Back | Close

Space required: 392.7MB
Space avalable: 24.6GB

Cancel | Mullsaft Install System vz, 46 < Back Install

4. The process will extract and install all the required
files to execute properly the Arduino Software (IDE).

@ Arduino Setup: Installing -

Extract: c++.exe

|

o)

Cancel | Mullsoft Install Syskem w2, 46 < Back Close |
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2.2. Configuring Arduino Board (Case Arduino Leonardo)

Connect the Arduino Leonardo board to your
computer using the USB cable and the Native USB
Port. If this is the first time you are connecting an
Arduino Leonardo Board to your computer, please
wait a few minutes before going on, as Windows
needs to install all the necessary drivers.

o

% LEONARDO

ARDUINO

Open Arduino IDE.

3. Open the “Boards Manager” in the Tools > Board

4.

menu.
File Edit Sketch Help —
Auto Format Crl+T
Archive Sketch
Fix Encoding & Reload

sketch_may24)

Arduino MKRZero
Arduino MKRFox1200

1 veid setug  Serial Monitor CtrlShifts M
; T2 PEE S Serial Plotter CtrlShift+L
4l WFLL0] Firmware Updater
H
. il Il
& void loop Board: "Arduino M0"
LERZE-X l Boards Manager...
. . Get Board Info T S 2 e R O Oe 2O
Arduino/Genuino Zerc (Programming Port)
2
G Arduino/Genuino Zero (Native USB Port)
Burn Bootload
urm Bootloader ‘ Arduino/Genuino MKRI00D

Bekafruiit Cirevit Plaunenind Fenress

Install latest version of "Arduino SAMD Boards (32-
Bits ARM Cortex M0O+)"

Boards Manager =
Type (a1 =] [Fiter your scarch...
Arduino SAM Boards (32-bits ARM Cortex-M2) by Arduino -

Boards included in this package:
Arduine Dus.

Cnline help.

Mors infe

Arduino SAMD Eoards (32-bits ARM Cortex-M0+) by Arduino
Boards included in this package:

Arduine/Genuine Zero.

Onlins help.

Mora infe

0

16.12v | [ Instal
Intel i586 Boards by Intel

Select the serial port number corresponding to the
Arduino board in the Tools > Port menu. The name
“Arduino Leonardo” should be associated with the
correct COM port.

& sketch_sep23a | Arduinc 1.8.8
File Edit Sketch Tools Help

Auto Format CtrleT
Archive Sketch
sketeh_sep23i iy Encoding & Reload

Manage Libraries... Ctrl Shift+|
Serial Monitor Ctri Shift+M
) Serial Plotter Ctrl+ Shift+L

WiFi101 / WiFiNINA Firmware Updater

Board: "Arduino Leonardo™ >
} Port: "COM3 (Arduino Leonardo)” 3 Serial ports
Get Board Info COM3

1 COMS (Ardui
Programmer: "AVRISP miil” COMY (iiduinoLeonando)

Burn Bootloader

Now, you need install Tronics EVB Library : Click on
“Add .ZIP Library...” in the Sketch > Include Library
menu.

55 sketch_may24a | A

File Edit Tools Help
Verify/Compile Ci+R
Upload Cir+U

Upload Using Programmer  Ctrl+ Shift+U
Export compiled Binary ~ Ctrl+Alt=S

Show Sketch Folder Ctrl+K

1 Include Library A ‘
Manage Libraries...
ol Add File...
// put your main code here, to run reps Add ZIP Library... ‘

Select “TronicsEvaluationKit_Library” in the “Arduino
Firmware & IDE” folder into the USB flash drive.

Now, you can open “EvaluationTool” firmware in the
Examples menu.

EvaluationTool | Arduine 1.8.5
[File] Edit Sketch Tools Help

New Crl+N

Open... Ctrl+0

Open Recent

Sketchbook

Examples &

Close CtrisW 08 Strings »

Save Ctrl+S 09.USB »

SaveAs..  Chl+ShiftsS 10 StarterKit_BasicKit »
11 ArduineISP »

PageSetup  Ctrl+Shift+P
Examples for any board

Print Ctrl+P

Adafruit Circuit Playground
Preferences  Ctrl+Comma ArduineCloud b
Quit Ctrl+Q Bridge G

45 #include <EVB.h> // Ry Tronics Evaluation Kit leraryr

" H ” s
5. Select “Arduino Leonardo” in the Tools > Board menu. s INCOMPATIELE ;
- valuationTool
E sketch_sep23a | Arduinc 1.8.3 17 void setup() |
sketch_sep23a | Arduino 1.8, 48 EVB.Init (ARDUINO_OUTH v GYPRO_ReadUutput
File Edit Sketch Tools Help -
Auto Format Ctrs T
Archive Sketch
Fix Encoding & Reload
Manage Libraries... Ctrl+ Shift+1
Serial Monitor Ctrls Shift+M
} Serial Plotter CtrleShift+L
Boards Manager...
WiFi101 / WiFiNINA Firmware Updater
Board: “Arduino Leonardo™ Arduino AVR Boards
) Port 3 Arduino Yin
Get Board Info Arduino/Genuino Uno
Programmer: "AVRISP " Arduino Duemilanove or Diecimila
Burn Bootloader sl
Arduine/Genuino Mega or Mega 2560
Arduine Meaa ADK
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2.3. Configuring Arduino Board

Connect the Arduino Leonardo or Yun board to your
computer using the USB cable and the USB Port. If
this is the first time you are connecting an Arduino
Board to your computer, please wait a few minutes
before going on, as Windows needs to install all the
necessary drivers.

Open Arduino IDE.

Select “Arduino Yun” or “Arduino Leonardo” in the
Tools > Board menu.

EvaluationTool | Arduino 1.8.5

File Edit Sketch Help

Auto Format CrleT
Archive Sketch

Fix Encoding & Reload

EvaluationToo

1 | peminnni T — P TP P ————
; Serial Plotter Ctrls+Shift+L
N WiFil01 Firmware Updater
8 Board: "Arduine Yin" &
. e ‘ Boards Manager... ‘
N Get Board Info. fatiina B B

10 Copy] ©  Arduino Yin

1 Programmer: "AVRISP mi"

12 Burn Bootloader ‘

o Arduino Di or Diecimila
13 ‘

14 Tro Arduino Nano

RIGUIRG] Senuno Uio ‘

Avcdesienr 2 resios e s cor bl 6T
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EvaluationToal | Arduino 1.8.5

File Edit Sketch Help

Auto Format Ctrl+T
Archive Sketch

EvaluationToo Fix Encoding & Reload
1 [ pawnnninnd Serial Monitor eI PR T S ——
; Serial Plotter Ctrl+Shift+L
N WiFil01 Firmware Updater
5
6 Board: "Arduino Yin" »
. Port (I E=——
g Get Board Info COM20 (Arduine Yun)
10 Copyy
1 Programmer: "AVRISP midl" 4
12 This Burn Bootloader
13

14 Tranira Fvaluatinn Tonl £ rwATe jarrib

Now, you- need install Tronics EVB LiBrary  Click on
“Add .ZIP Library...” in the Sketch > Include Library
menu.

[=5) sketch_may24a | Ar

File Edit Tools Help

Verify/Compile Ctrl+R
Upload Ctrl+U
Upload Using Programmer  Ctrl+Shift+U

Export compiled Binary Ctrl+Alt+5

Show Sketch Folder Ctrl+K
Include Library 4
’ A Manage Libraries...
7 // put your main code here, to run repf Add ZIP Library... ‘

Select “TronicsEvaluationKit_Library” in the “Library
Evaluation-Kit” folder.

Now, you can open “EvaluationTool” firmware in the
Examples menu.

EvaluationTool | Arduino 1.85
[File] Edit Sketch Tools Help

MNew Ctrl+N
Open... Ctrl+0
. . Open Recent
Select the serial port number corresponding to the Sketchbook
Arduino board in the Tools > Port menu. The Arduino P Bings .
board should be associated with the correct COM Sove Cties 09.Us8 ’
Saveds.  ChleShifteS 10.StarterKit_BasicKit »
port. 11 ArduinolSP v
Page Setup  Ctrl+Shift+P
Print CtrleP Examples for any board
Adafruit Circuit Playground *
Preferences  Ctrl+Comma ArduinoCloud b
Quit Crl+Q Bridge ’W o
45 #include <EVB.R> // Ry Tronics Evaluation Kit leraryr A¥D RaadOutout.
:f void setup() { INCOMPATIBLE EvaluationTool
42 EVB.Init (PRDUINC;CUIE‘,V—‘M,
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2.4. Configuring Arduino Firmware

1. Edit the line 38 of the firmware: According your evaluation board, you need to change the value by:
- EVB2.0 = EVB_VERSION 20
- EVB2.1 > EVB_VERSION 21
- EVB3.0 > EVB_VERSION 30 (default value)

€9 EvaluationTool | Arduino 1,810 — O *
Fichier Edition Croguis Outils Aide

EvaluationTool

37 #define RRDUINC CUTFUT SerialUSB ff <== Define Cuput Port name (USB Port = 5erialUSB ; R5422 Port = Seriall)
35 #define EVE VERSICOH 30 ff <== Define EVB Version (21 for EVB 2.1, 30 for EVB 3.0}

L NP

43 J/ GLOBAL INITIALISATIONS r

Arduino MO sur COM17

2. Upload the program: Simply click on the "Upload" button in the environment. Wait a few seconds, and you should see the
RX and TX LEDs on the board flashing. If the upload is successful, the message "Done uploading." will appear in the status
bar at the bottom of the window.

7 Upload

3. Close Arduino IDE

=>» NOW YOUR ARDUINO BOARD IS PROGRAMMED AND READY TO BE USED WITH TRONICS EVALUATION TOOL.
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2.5. Assembling EVB with Arduino Board

4. Disconnect your Arduino board from the computer, since the Arduino Board should be switched-off for the next step.

5. For EVB3.0: Add a Jumper to J9 connector between “5V” and “VDDIO REF” pins. This will apply the same reference voltage

for SPI signals as the Arduino board.

Note : It is important to ensure that the VDDIO voltage matches the SPI voltage of the Arduino (or any other Arduino-

compatible shield). A difference in voltage may cause the sensor device to overheat, resulting in degraded performance.

6. Plug the GYPRO® or AXO® Evaluation Board on the Arduino Board, using the 5 connectors supplied by Tronics. The correct

position is to have the Arduino board on top (above the Evaluation board).

7. Connect the Arduino Board to your computer using the USB cable and the Native Port.

8. Now you can launch Tronics Evaluation Tool.exe software on your computer!
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3. Basic Operation of Tronics Evaluation Tool Software

The Evaluation Tool is made of 5 tabs:
e Reading GYPRO® / AXO® (Main Tab):

Reads the sensor data (Angular rate / Linear
Acceleration and Temperature) and displays
them on two real-time charts.

System Register (SR):
Enables reading, writing or changing the output
format of the data (Raw, Compensated or
Calibrated) by modifying the sensor System
Register.

Multi-Time-Programmable (MTP):
Useful to read and program new temperature
compensation coefficients in the MTP of the
sensor.

Others:
To check Software and Hardware Self-Test, to
read Drive Frequency, to measure Start-Up Time
and to generate debug reports for Tronics
support team.

Compass / Plane:
Displays a real-time compass using GYPRO® or a
plane using AXO®.

Once the Arduino board is detected by the software, you can click on the top left power ON/OFF button. The application will
start and read the sensor information (serial number and type of sensor).

Once the Arduino board is detected by the software, you can click on the top left power ON/OFF button. The application will
start and read the sensor information (serial number and type of sensor). Please choose the correct product you are currently

testing in the list proposed.
=

=
T

Choose an Acquisition time (1s minimum) and click on the “Start/Stop” button.
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=>» FOR DETAILED DESCRIPTION OF TRONICS EVALUATION TOOL SOFTWARE PLEASE READ THE DOCUMENT TRONICS EVALUATION KIT —
SOFTWARE USER MANUAL
4. Available Tools and Resources
The following tools and resources are available on GYPRO® and AXO® webpages of Tronics website.

Description
Item

Documentation & technical notes
3

GYPRO4300 - Datasheet

AXO3XX - Datasheets

Mechanical tool

w GYPRO®4000 Series and AXO®300 Series - 3D model
Evaluation kit
“““ Tronics EVB3 — Evaluation board
? Evaluation board for AXO315 and GYPRO4300, compatible with Arduino Leonardo and
Arduino Yin
‘,ITIJ Tronics Evaluation Tool — Software
Evaluation
a

Tronics EVB3 — User manual

2,
/470 . . . . .
W Tronics Evaluation Kit — Quick Start Guide
Q— Tronics Evaluation Tool — Software User Manual
v@ Tronics Evaluation Tool — Arduino Firmware
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Should you encounter any issue while using GYPRO® or AXO® Evaluation Kit, please contact Tronics technical support by
sending an email to support.tronics@tdk.com.
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