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Features

This user manual is intended for customers who have purchased GYPRO® or AXO® Evaluation Board and who would like to
implement it using Arduino platform. The following paragraphs explain how to set-up the full evaluation kit and how to
configure Arduino Leonardo or Yun Rev.2 board.

Required:

- GYPRO® or AXO® EVB

- Header Connectors (x5)

- Arduino Leonardo board or Arduino Yun Rev. 2 Board (not included).
- Micro-B USB Cable (not included).

- Computer running Window 7 or later version with USB port.

Note: If you intend to perform tests over temperature, make sure that your USB Cable can withstand the operating temperature
range specified by Tronics

1. System Requirements

Tronics Evaluation Tool software is compatible with OS Windows 7 or later versions. The program automatically adapts to the
operating system on which it runs, eliminating the need for manual settings.

Recommended system configuration:

* Processor 1.6 GHz or faster

* 2GBRAM

* 1280*960 pixels minimal screen resolution

* 780 MB free hard disk space for the Arduino IDE and the Tronics Evaluation Tool software (additional space is needed
during installation only to accommodate the initial setup files).

* USB Port.

* Operating Systems: Windows 7, Windows Server 2008 R2, Windows Thin PC, Windows 8 / 8.1, Windows RT, Windows
Server 2012 and Windows 10.
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2. Setting Up
2.1. Installing Arduino IDE

1. |Install open-source Arduino software (IDE)
1.X.X.windows.exe (please authorize the driver
installation process).

NOTE: link to the software version is available on our

website.

e - X

Chedk the components you want to install and uncheck the components
S5 you don't want to install. Click Next to continue.

Select components to install: Install Arduino software
Install USB driver

eate Start Menu shortcut
Create Desktop shortcut

Assodiate .ino files
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this package if you don’t use other boards than the
Arduino Leonardo or Arduino Yun in the future.

- Atmel USB Driver Package Setup - X

,’- Atmel USB Driver Package

Modify Setup

Repair Uninstall Close

Space required: 392, 7MB 6. Once the status “Completed” is displayed, Arduino
IDE is installed and is ready to be used. You can close
Cancel | Nullsaft Install System w2, 46 < Back Next > the Insta | Ier.
. 9 Arduino Setup: Completed -
2. Select all the components and then click on “Next” < Arduino Setup: Complete
button. Eate ]
3. Choose the installation directory (we suggest keeping _ Showdetais |
the default one) then click on the “Install” button.
@ Arduino Setup: Installation Folder — >
Setup will install Arduine in the following folder. To install in a different
folder, dlick Browse and select another folder. Click Install to start the
installation.
Destination Folder
Cancel Mullsaft Install System < Back Close
’7 C:\Program Files (x86)\Arduino Browse... | —I —I ———
Space required: 392.7MB
Space available: 24.6GB
Cancel | Mullsaft Install System vz, 46 < Back
4. The process will extract and install all the required
files to execute properly the Arduino Software (IDE).
@ Arduino Setup: Installing -
for0) Extract: c++.exe
]
Cancel | Mullsoft Install Syskem w2, 46 < Back Close |
5. Theinstallation of Arduino IDE includes “Atmel USB
Driver Package” installation. You don’t need to install
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2.2. Configuring Arduino Board (Case Arduino Leonardo)

Connect the Arduino Leonardo board to your
computer using the USB cable and the Native USB
Port. If this is the first time you are connecting an
Arduino Leonardo Board to your computer, please
wait a few minutes before going on, as Windows
needs to install all the necessary drivers.

x
LEONARDO

ARDUINO

- 3
ﬂ (=
o

I

..
141
| o

@ oo

o I

Open Arduino IDE.

3. Open the “Boards Manager” in the Tools > Board

4.

menu.
File Edit Sketch Help —
Auto Format Crl+T
Archive Sketch
sketeh may2| gy e coding & Reload

Arduino MKRZero
Arduino MKRFox1200

1 veid setug  Serial Monitor CtrlShifts M
; T2 PEE S Serial Plotter CtrlShift+L
4l WFLL0] Firmware Updater
H
. il Il
& void loop Board: "Arduino M0"
LERZE-X l Boards Manager...
. . Get Board Info T S 2 e R O Oe 2O
Arduino/Genuino Zerc (Programming Port)
2
G Arduino/Genuino Zero (Native USB Port)
Burn Bootload
urm Bootloader ‘ Arduino/Genuino MKRI00D

Bekafruiit Cirevit Plaunenind Fenress

Install latest version of "Arduino SAMD Boards (32-
Bits ARM Cortex M0O+)"

Boards Manager =
Type (a1 =] [Fiter your scarch...
Arduino SAM Boards (32-bits ARM Cortex-M2) by Arduino -

Boards included in this package:
Arduine Dus.

Cnline help.

Mors infe

Arduino SAMD Eoards (32-bits ARM Cortex-M0+) by Arduino
Boards included in this package:

Arduine/Genuine Zero.

Onlins help.

Mora infe

0

16.12v | [ Instal
Intel i586 Boards by Intel

Select the serial port number corresponding to the
Arduino board in the Tools > Port menu. The name
“Arduino Leonardo” should be associated with the
correct COM port.

& sketch_sep23a | Arduinc 1.8.8
File Edit Sketch Tools Help

Auto Format CtrleT
Archive Sketch
sketeh_sep23i iy Encoding & Reload

Manage Libraries... Ctrl Shift+|
Serial Monitor Ctri Shift+M
) Serial Plotter Ctrl+ Shift+L

WiFi101 / WiFiNINA Firmware Updater

Board: "Arduino Leonardo™ >
} Port: "COM3 (Arduino Leonardo)” 3 Serial ports
Get Board Info COM3

1 COMS (Ardui
Programmer: "AVRISP miil” COMY (iiduinoLeonando)

Burn Bootloader

Now, you need to install Tronics EVB Library: Click on
“Add .ZIP Library...” in the Sketch > Include Library
menu.

55 sketch_may24a | A

File Edit Tools Help
Verify/Compile Ci+R
Upload Cir+U

Upload Using Programmer  Ctrl+ Shift+U

1 Export compiled Binary  Ctrl+Alt=S

2 7/

3 Show Sketch Folder Ctrl+K

N Include Library A

- Manage Libraries...

& voi Add File...

7 4/ put your main code here, to run repd Add ZIP Library... ‘
ah P \

Select “TronicsEvaluationKit_Library” in the “Library-
Evaluation-Kit” folder.

Now, you can open “EvaluationTool” firmware in the
Examples menu.

EvaluationTool | Arduine 1.8.5
[File] Edit Sketch Tools Help

New Crl+N

Open... Ctrl+0

Open Recent

Sketchbook

Examples &

Close CtrisW 08 Strings »

Save Ctrl+S 09.USB »

SaveAs..  Chl+ShiftsS 10 StarterKit_BasicKit »
11 ArduineISP »

PageSetup  Ctrl+Shift+P

Print CtrleP Examples for any board

Adafruit Circuit Playground
Preferences  Ctrl+Comma ArduineCloud b
Quit Ctrl+Q Bridge G

45 #include <EVB.h> // Ry Tronics Evaluation Kit leraryr

" H ” s
5. Select “Arduino Leonardo” in the Tools > Board menu. s INCOMPATIELE ;
- valuationTool
E sketch_sep23a | Arduinc 1.8.3 17 void setup() |
sketch_sep23a | Arduino 1.8, 48 EVB.Init (ARDUINO_OUTH v GYPRO_ReadUutput
File Edit Sketch Tools Help -
Auto Format Ctrs T
Archive Sketch
Fix Encoding & Reload
Manage Libraries... Ctrl+ Shift+1
Serial Monitor Ctrls Shift+M
} Serial Plotter CtrleShift+L
Boards Manager...
WiFi101 / WiFiNINA Firmware Updater
Board: “Arduino Leonardo™ Arduino AVR Boards
) Port 3 Arduino Yin
Get Board Info Arduino/Genuino Uno
Programmer: "AVRISP " Arduino Duemilanove or Diecimila
Burn Bootloader sl
Arduine/Genuino Mega or Mega 2560
Arduine Meaa ADK
ref. : MCDO010-F ©Copyright 2024 Tronic’s Microsystems S.A.. All rights reserved. Page 3

Specification subject to change without notice.


http://www.tronicsgroup.com/

tronicsl|ll

Evaluation Kit Quick-start Guide

2.3. Configuring Arduino Board (Case Arduino Yun)

1. Connect the Arduino Yun board to your computer
using the USB cable and the USB Port. If this is the
first time you are connecting an Arduino Yun Board to
your computer, please wait a few minutes before
going on, as Windows needs to install all the
necessary drivers.
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Now, you need to install Tronics EVB Library: Click on
“Add .ZIP Library...” in the Sketch > Include Library
menu.

File Edit Tools Help
Verify/Compile Cirl+R
Upload Cirl+U

Upload Using Programmer  Ctrl+ Shift+U

v
)
e
=
=
3
8
3
<

oh |

1 Export compiled Binary  Ctrl+Alt+S

2 7/

3 Show Sketch Folder Ctrl+K

N Include Library A ‘
- Manage Libraries...

& voi Add File...

Add .ZIP Library... ‘

ARDUINO

2. Open Arduino IDE.

3. Select “Arduino Yin” in the Tools > Board menu.
EvaluationTool | Arduino 1.85
File Edit Sketch Help
Auto Format Ctrl+T
Archive Sketch

EvaluationToo| Fix Encoding & Reload
Y pr— Serial Monitor CtrbeShifte M [f 44+ e s sms s s s
i Serial Plotter Cerl+Shift-L
N WiFil01 Firmware Updater
5
N Board: "Arduine Yin" j & ‘
7 ot Boards Manager...
N Get Board Info TSRS L R :
10 — ©  Arduino Yin
n Programmer: "AVRISP midl"
12 This Burn Bootloader Arduing D or Diecimila

13
14

1=

‘ RIGUIRG] Senuno Uio
Arduino Mano ‘

Aedvsimn f2mmrsimn Mmmn ~r hdnmn IEEN

4. Select the serial port number corresponding to the
Arduino board in the Tools > Port menu. The name
“Arduino Yun” should be associated with the correct
COM port.

EvaluationTool | Arduinc 1.8.5

File Edit Sketch Help

Auto Format Crl+ T
Archive Sketch

Select “TronicsEvaluationKit_Library” in the “Library-
Evaluation-Kit” folder.

Now, you can open “EvaluationTool” firmware in the
Examples menu.

EvaluationTool | Arduino 1.8.5
[File] Edit Sketch Tools Help

New Ctrl+N
Open..  CulvO
Open Recent
Sketchbook
Examples
Close Clew 08.Strings ,
Save Crles 09.UsB >
Sovehs.  CulsShift-S 10.StarterKit_Basicit ,
11 ArduinclsP ,
Page Setup  Ctrl+Shift-P
Print — Examples for any board
Adsfruit Circuit Playground
Preferences  Ctrl+Comma ArduinoClond .
Quit Ctrl+Q Bridge 4
45 fincluce VB> // B8 Tronics Evalustion Kit Library) s AXOLR
o lvosa etun ) INCOMPATIBLE EvalustionTool
48 EVB.Init [PR:“JIITC'_C‘UIE—V‘M,

EvaluationToo Fix Encoding & Reload
1 | pusssnssny - CUE-SRIEEM [k s sk s
; Serial Plotter Ctrl+ Shift+L
N WiFiL01 Firmware Updater
5
§ Board: "Arduino Yun" 4
N Port I —
5 Get Board Info COM20 (Arduino Yiin)
10 opyT]
11 Programmer: "AVRISP mkil" 4
12 Burn Bootloader
13
18 Tronins Fvaluatinn Tanl is free snffware: won man redistribuote it a
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2.4. Configuring Arduino Firmware

1. Edit the line 38 of the firmware: According your evaluation board, you need to change the value by:
- EVB2.0 = EVB_VERSION 20
- EVB2.1 > EVB_VERSION 21
- EVB3.0 > EVB_VERSION 30 (default value)

€9 EvaluationTool | Arduino 1,810 — O *
Fichier Edition Croguis Outils Aide

EvaluationTool

37 #define RRDUINC CUTFUT SerialUSB ff <== Define Cuput Port name (USB Port = 5erialUSB ; R5422 Port = Seriall)
35 #define EVE VERSICOH 30 ff <== Define EVB Version (21 for EVB 2.1, 30 for EVB 3.0}

L NP

43 J/ GLOBAL INITIALISATIONS r

Arduino MO sur COM17

2. Upload the program: Simply click on the "Upload" button in the environment. Wait a few seconds, and you should see the
RX and TX LEDs on the board flashing. If the upload is successful, the message "Done uploading." will appear in the status
bar at the bottom of the window.

Upload

3. Close Arduino IDE

=>» NOW YOUR ARDUINO BOARD IS PROGRAMMED AND READY TO BE USED WITH TRONICS EVALUATION TOOL.
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2.5. Assembling EVB with Arduino Board

4. Disconnect your Arduino board from the computer, since the Arduino Board should be switched-off for the next step.
5. For EVB3.0): Add a Jumper to J9 connector between “3V3/EXT” and “VDDIO REF” pins. This will apply the same reference
voltage for SPI signals as the Arduino board.
R2
T
E
1
"
6.

Plug the GYPRO® or AXO® Evaluation Board on the Arduino Board, using the 5 connectors supplied by Tronics. The correct
position is to have the Arduino board on top (above the Evaluation board).

7. Connect the Arduino Board to your computer using the USB cable and the Native Port.

8. Now you can launch Tronics Evaluation Tool.exe software on your computer!
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3. Basic Operation of Tronics Evaluation Tool Software

The Evaluation Tool is made of 5 tabs:
e Reading GYPRO® / AXO® (Main Tab):

Reads the sensor data (Angular rate / Linear
Acceleration and Temperature) and displays
them on two real-time charts.

System Register (SR):
Enables reading, writing or changing the output
format of the data (Raw, Compensated or
Calibrated) by modifying the sensor System
Register.

Multi-Time-Programmable (MTP):
Useful to read and program new temperature
compensation coefficients in the MTP of the
sensor.

Others:
To check Software and Hardware Self-Test, to
measure Start-Up Time and to generate debug
reports for Tronics support team.

Compass / Plane:
Displays a real-time compass using GYPRO® or a
plane using AXO®.

Arduino Leonardo (COM7

—n Ready to connect !

BI]

Once the Arduino board is detected by the software, you can click on the top left power ON/OFF button. The application will
start and read the sensor information (serial number and type of sensor). Please choose the correct product you are currently

testing in the list proposed.

VALIDER ks

Choose an Acquisition time (1s minimum) and click on the “Start/Stop” button.

X

A2TDK

Arduino Leonardo (COMT)
eady to connect !

Power
button

Start/Stop
button

Record Acquisition

e [

tronics(il

=>» FOR DETAILED DESCRIPTION OF TRONICS EVALUATION TOOL SOFTWARE PLEASE READ THE DOCUMENT TRONICS EVALUATION KIT —
SOFTWARE USER MANUAL
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The following tools and resources are available on GYPRO® and AXO® webpages of Tronics website.

Description
Item

Documentation & technical notes

O
GYPRO4300 - Datasheet

AX0315 - Datasheet

GYPRO2300 / GYPRO2300LD - Datasheet

GYPRO3300 - Datasheet

Mechanical tool

w AX0315 and GYPRO4300 - 3D model

GYPRO2300 & GYPRO3300 - 3D model

Evaluation kit

Arduino Yin

Tronics EVB2 — Evaluation board

Evaluation board for GYPRO2300 series and GYPRO3300 series, compatible with Arduino
Leonardo and Arduino Yun

Tronics EVB3 — Evaluation board
9 Evaluation board for AXO315 and GYPRO4300, compatible with Arduino Leonardo and

Tronics Evaluation Tool — Software

Evaluation

a
Tronics EVB3 — User manual
a .
Tronics EVB2 — User manual
50 Tronics Evaluation Kit — Quick Start Guide
Q Tronics Evaluation Tool — Software User Manual

9 Tronics Evaluation Tool — Arduino Firmware

Should you encounter any issue while using GYPRO® or AXO® Evaluation Kit, please contact Tronics technical support by
sending an email to TEG-ECR-support@tdk.com.
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